[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
FREESCO Support • View topic - NTP 4.1.1: Missing TZ file

NTP 4.1.1: Missing TZ file

Support section for FREESCO v0.4.x 3rd Party Packages

NTP 4.1.1: Missing TZ file

Postby Island » Mon Aug 29, 2011 12:09 pm

Finally getting around to installing the NTP full package on FREESCO 042. The install script aborts saying that it needs a timezone file. I used a file from an earlier modules.zip, modules 040, but the install didn't like it. (I'd put it in /mnt/bootdev/router/tmz/; file permissions were 777). Assuming it needed a file from modules 042 zip, I downloaded that from:

http://prdownloads.sourceforge.net/free ... es-042.zip

but neither Windows (Vista) nor Linux (Debian) like the 'zip'; they both complain the zip is invalid.

Anyone else seeing the same thing, an invalid zip?

Alternatively, are there some timezone files somewhere else in the FREESCO mirrors? (I could only see 'pkg' files.)

regards, Island
User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm

Re: NTP 4.1.1: Missing TZ file

Postby Lightning » Tue Aug 30, 2011 6:08 am

If you are having problems with the 043 modules then get the 043 tar.gz or the 043 zip version which includes the modules inside that file.
Also permissions on the file when finished should be something like 644 and if you continue to have issues you might try a different file because usually there are two or three that will work for a timezone and more than one directory location to find them.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: NTP 4.1.1: Missing TZ file

Postby Island » Tue Aug 30, 2011 6:52 am

Hmm .. .. Workstation is reporting the 043 'zip' as invalid, as well. It must be me, though. Here's some info:

Download site: http://freesco.sourceforge.net/
Downloaded Modules 042 zip size: 13.4 kb
Downloaded twice: via Win Firefox, and via Kget/Wget; same file size)
Downloaded FREESCO 043 zip: 13.5 kb (via Win Firefox)
Downloaded FREESCO 043 tar/gz: 13.5 kb (via Win Firefox)

These all seem to be too small.

Am I using the correct site? (Linked from http://lewys-spot.dyndns.org/)

I must be doing something really silly, and I do apologise, but could somebody just point me in the right direction?


SOLVED!

The links on that page are not 'zips' at all. They are html pages which take you to a sourceforge download page. I was right-clicking and saving, but in fact they expect you just to click on the link. (We generally don't click on links like these (which show in the browser status bar as a 'zip' file) because we don't want to run the risk of any auto-execution. )


Very many thanks.

Island
User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm

Re: NTP 4.1.1: Missing TZ file is actually there, but ..

Postby Island » Tue Aug 30, 2011 7:41 am

Still a problem installing this package.

The install gives up complaining that:

*** You must install a timezone file from the modules zip 042

This is just after the script says checking if the package is installed ...Ok

In fact, I have installed a timezone file. It was FTPd to root's home from our main NFS filestore, and then copied (using mc on FREESCO) into /boot/tmz, following the guidance in the timezone folder of the 042 zip.

The script now also says:

rm: /boot/16406~: Device or resource busy

It says this twice.

I'll try restarting FREESCO, in case the timezone file needs to have been detected and in use in some sense.

regards, Island
User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm

Re: NTP 4.1.1: Missing TZ file- SOLVED

Postby Island » Wed Aug 31, 2011 9:20 am

Restarting FREESCO solved the missing TZ file problem. So, the procedure to follow, if installing ntp 4.1.1, is

(a) Install a timezone file, from 'modules' zip file, into /boot/tmz directory
(b) Restart FREESCO (I actually rebooted it)
(c) Install package ntp-4.1.1-lightning.pkg

Now, I found that the install script 'hung' at the last stage. I was controlling via SSH. It seemed ok this far:

(i) installing package
(ii) Time server: (with remarks about stratum, adjustment, etc)
(iii) Please wait while adjusting time ...

Then, the script said:

(iv) Setting NAT and Firewall

and just 'hung', no prompt, no Ok, eventually breaking the SSH connection

Not sure what happened, there.


Tested using a Windows client on the LAN - which failed, reporting that the 'peer stratum' was lower than 'host stratum' which presumably meant that the Windows client had a higher stratum clock than FREESCO has now. (Of course, it's a basic Windows Vista machine, and has no type of stratum clock at all.)

regards, Island
User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm

Re: NTP 4.1.1: Missing TZ file

Postby Lightning » Wed Aug 31, 2011 8:00 pm

The stratum servers that you use are set in the package. However if you want to use higher stratum servers you definitely can, it is just a matter of looking them up and setting them in the ntp configuration.

rc_ntpd setup

In order to get the server up to a stratum 2 server means that you need to update from at least one stratum 1 server. If you just use stratum 2 servers then your server will be a stratum 3 server. There are some stratum 1 servers available to get updates without paying a fee or having a login if you do a search for them and can find one that is not to far away to keep accuracy.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: NTP 4.1.1: Missing TZ file

Postby Island » Thu Sep 01, 2011 5:00 am

User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm

Re: NTP 4.1.1: Missing TZ file

Postby Island » Thu Sep 01, 2011 10:30 am

User avatar
Island
Junior Advanced Member
 
Posts: 117
Joined: Sat Jan 22, 2005 12:48 pm


Return to 3rd Party Package Support for FREESCO v0.4.x

Who is online

Users browsing this forum: No registered users and 1 guest