[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
FREESCO Support • View topic - Unable to get port forwarding to work

Unable to get port forwarding to work

Support section for FREESCO v0.4.x

Unable to get port forwarding to work

Postby alucard » Thu Mar 15, 2012 7:04 am

Hello Everyone,
I've set up FreeSCO using the HD method and everything looks to be working. My only road block is that i cant seem to forward ports. I have a pretty simple setup that I'm using to separate some testing environments from my main network. I have 2 nics. eth0 is connected to my main network (192.168.0.x) and eth1 is connected to my testing network (172.0.2.x). I have enabled port forwarding and the default Firewall/NAT setting inside setup. I am trying to forward port 22 to 172.0.2.2 but i get the below:

Mar 15 06:57:05 - kernel: IP fw-in rej eth0 TCP 192.168.0.181:64497 172.0.2.2:22 L=48 S=0x00 I=6720 F=0x4000 T=128

I've also tried port 80 and i get the same thing. I'm missing something but i can't seem to figure it out. I tried searching and some of the sites say to manually add the ipfw -l accept (etc, etc) to i think rc_user file but they are all for 0.3.x. i cant seem to find anything for 0.4.4. Eventually I will have several servers on the 172.0.2.x network that i will need to access via port 22, 80 and several others.

Thank you.
alucard
Newbie
 
Posts: 4
Joined: Wed Mar 14, 2012 1:31 pm

Re: Unable to get port forwarding to work

Postby ChrisW » Thu Mar 15, 2012 12:45 pm

I checked with my 0.4.2 Freesco, which has a working forwarding setup, but no allows in my rc_user (at least not for the stuff I'm forwarding).

Something that has bitten me in the past, so just checking, does the control panel show up the forwarding rules you put in correctly? Are there no messages during the boot in the log hinting at some malformed entry?

Finally, 192.168.x.x are reserved nets, so are 172.16.x.x - 172.31.x.x, but 172.0.2.x is not. Just wondering if there's an issue with forwarding from a private network to a non-private network? Wiki says "These addresses are characterized as private because they are not globally delegated, meaning they are not allocated to any specific organization, and IP packets addressed by them cannot be transmitted onto the public Internet".
ChrisW
Newbie
 
Posts: 9
Joined: Thu Jan 05, 2012 10:24 am

Re: Unable to get port forwarding to work

Postby alucard » Thu Mar 15, 2012 12:57 pm

Hi Chris,

In the control panel under Port Forwarding I get the below when i select list:

-- cat /etc/portfw.cfg --


tcp,22,22,172.0.2.2 # SSH
tcp,80,80,172.0.2.2 # apache

I don't see anything unusual in the system or recent log files. The only thing i do get during boot up is: "!** WARNING Insecure **!" for port forwarding but thats because of the way i have it set up i believe.

I can try to give the network behind FreeSCO a different IP addressing scheme. I was using 172.x.x.x so that i was 100% sure it wouldn't interfere with my main network of 192.x.x.x. When i take off the NAT/firewall in advanced options, I'm able to SSH to that server from my 192..x.x.x machine to the 172.x.x.x server.
alucard
Newbie
 
Posts: 4
Joined: Wed Mar 14, 2012 1:31 pm

Re: Unable to get port forwarding to work

Postby ChrisW » Thu Mar 15, 2012 2:02 pm

Interesting, I certainly don't get the 'Warning Insecure' message with 0.4.2, but perhaps it's a new feature. Did you fully configure before going to the HD, or just got to ext2 as quick as possible and copied over? The message might mean your not fully setup yet. Other than that, it could be post the config file time....
ChrisW
Newbie
 
Posts: 9
Joined: Thu Jan 05, 2012 10:24 am

Re: Unable to get port forwarding to work

Postby alucard » Thu Mar 15, 2012 4:13 pm

I did the initial setup from the floppy but once thw wizard was finished i rebooted once more from the floppy to make sure it saved. I then installed the ext2 pkg and moved it to the hard drive. once it was on the hard drive i configured the second nic, and enabled port forwarding.

for the config files which ones should i paste?
alucard
Newbie
 
Posts: 4
Joined: Wed Mar 14, 2012 1:31 pm

Re: Unable to get port forwarding to work

Postby Lightning » Thu Mar 15, 2012 5:36 pm

If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Re: Unable to get port forwarding to work

Postby alucard » Fri Mar 16, 2012 7:08 am

Lightning,
I think my issue is because I am not using DHCP. The servers will need to have a static IP on the seperate environment. But if i can set them up for dhcp and make it so that they can keep the IP address i think that will work. is there a doc on how to do it?

Also, I am assuming the warning is for port forwarding because the message is below the Starting port forwarding... line :)

Attached is the report.txt and a pic of the warning message.

Thank you for all of your help.
You do not have the required permissions to view the files attached to this post.
alucard
Newbie
 
Posts: 4
Joined: Wed Mar 14, 2012 1:31 pm

Re: Unable to get port forwarding to work

Postby Lightning » Fri Mar 16, 2012 7:21 pm

If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12081
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA


Return to FREESCO Support for v0.4.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron