Page 1 of 1

Exim, outbound to smarthost, port 465

PostPosted: Wed Nov 03, 2010 12:00 pm
by Island
Apologies if it's been asked before, a search for a forum entry with Exim, 465, SMTP, didn't show anything.

Used Exim on Freesco in the past, had it working well. Used the FAQ/Wiki guidance at:

http://dingetje.homeip.net/dokuwiki/fre ... ail_server

Now, Freesco is on a mobile carrier, and I want to route outbound email through a (different) paid-for SMTP service using SSL on port 465. (Mobile carrier recommends doing this, and handheld clients seem to manage it ok, so the carrier does route port 465 traffic correctly.)

I could not see anywhere in the Exim conf file to stipulate using port 465. I've said

hosts_require_auth = the.paidfor.server

and set up a LOGIN auth stanza with
client_send = ^me^mypass

But the connection is failing and I think it needs to use port 465.
Is it possible to do this, and where should I configure the port?

Any help much appreciated,

regards, Island

Re: Exim, outbound to smarthost, port 465

PostPosted: Fri Nov 12, 2010 2:58 pm
by dingetje
I'm not sure if the exim package for FREESCO is compiled with SSL support in it.
You can try adding this:

Code: Select all
tls_on_connect_ports = 465


and then at the smarthost:
Code: Select all
hosts_require_tls = the.paidfor.server

Re: Exim, outbound to smarthost, port 465

PostPosted: Fri Nov 12, 2010 3:12 pm
by dingetje
I've googled a bit an this may work:

http://www.manu-j.com/blog/wordpress-ex ... l-smtp/75/

The ''tls_on_connect_ports = 465' is only for receiving and is not used for sending (or so I've read elsewhere)