How to determine what libs are required

If you need some help, this should be the first place to look.

Postby dingetje » Thu Apr 25, 2002 6:13 am

Q: How can I tell what libraries are required for a specific program?

A: Use the ldd program. This tool can be found in the zipslack 3.9 distribution and works on FREESCO.

Example:
Code: Select all
[Linux] ldd webalizer
        libpng.so.3 => /lib/libpng.so.3 (0x40009000)
        libm.so.5 => /lib/libm.so.5 (0x40046000)
        libdb.so.1 => /lib/libdb.so.1 (0x4004f000)
        libc.so.5 => /lib/libc.so.5 (0x4005f000)




<!--EDIT|dingetje|April 25 2002,12:14-->
dingetje
 

Return to FAQ - Frequently Asked Questions

Who is online

Users browsing this forum: No registered users and 2 guests

cron