Msql And Apache Not Working

Support section for FREESCO v0.3.x 3rd Party Packages

Postby shamrockspider » Sat Nov 01, 2008 4:24 am

Have fired up my development Webserver (Freesco) a couple days ago and found it was not working properly. Have tried sorting out what is going wrong but am now not making progress.
Believe it was working OK last time I used it back in 2007.
Mysql appears to be throwing up errors and Apache does not appear to run as php files not displaying.
The Alt F1 Screen shows mysql starting, phpmyadmin starting, but no sign of apache.
When I run my FTP application it is defaulting to /mnt/bootdev/router/pkg/home/root/ on the server when I am expecting it to go to /mnt/bootdev/router/www/
Attached is a report file.
Any clues greatly appreciated.
<b>Regards Kevin</b><br>Learn from the mistakes of others, you don't have time to make them all yourself!
User avatar
shamrockspider
Newbie
 
Posts: 6
Joined: Sun Sep 26, 2004 3:58 pm

Postby Lightning » Sat Nov 01, 2008 11:41 am

Looking at the report mysql is running, however the web server is not and this is why
ENAWWW=n   #441 HTTP Server

You have disabled the web server in the main setup and even though Apache is a package it actually uses this setting to know whether to start or not. So run the advanced setup and enable the web server then use

rc_httpd restart
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 3048
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Postby shamrockspider » Sat Nov 01, 2008 2:17 pm

Apologies for posting in the wrong forum.
have restarted the http server as suggested but makes no difference.
Will post more once you have moved to the correct forum.
<b>Regards Kevin</b><br>Learn from the mistakes of others, you don't have time to make them all yourself!
User avatar
shamrockspider
Newbie
 
Posts: 6
Joined: Sun Sep 26, 2004 3:58 pm

Postby Lightning » Sat Nov 01, 2008 7:04 pm

When I run my FTP application it is defaulting to /mnt/bootdev/router/pkg/home/root/ on the server when I am expecting it to go to /mnt/bootdev/router/www/
The FTP server always goes to the home directory of the user you login with. So if you want to go to the www directory you can add a symlink that will get you there using the following command.
Code: Select all
ln -s  /www  /home/root/www
Also please provide a new report.txt with the changed configuration.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 3048
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Postby dingetje » Sat Nov 01, 2008 7:34 pm

First thing to look is the Apache error log in /usr/local/apache/logs.
GreetZ
http://dingetje.homeip.net

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1004
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands


Return to 3rd Party Package Support for FREESCO v0.3.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron