I Need Some Modules For Apache

Support section for FREESCO v0.3.x 3rd Party Packages

Postby Burma » Mon Feb 25, 2008 4:53 pm

Hello,

I have Freesco 0.37 with Apache (apache_1.3.27_dingetje) and i try to install <a href='http://mediacenter.neuf.fr/premier_contact.html' target='_blank'>this</a> which, in fact, is a web server to share multimedia files on a TV with a decoder provided by my ISP.
But in the config file (httpd.conf) there are some modules that are not compiled in the apache package for Fressco, and not provided in the /usr/local/apache/libexec directory.
Those modules are : mod_mime_magic.so and mod_authz_host.so. So if somebody can compile them it will help me a lot.

Thanks in advance and sorry for my bad english.
User avatar
Burma
Newbie
 
Posts: 13
Joined: Tue May 04, 2004 12:58 pm
Location: Angers, FRANCE

Postby dingetje » Tue Feb 26, 2008 1:56 am

I believe mod_authz_host is an Apache 2 module, for Apache 1.3 you'll have to use mod_access which is default enabled in the package.
<a href='http://www.anyexample.com/linux_bsd/apache/restrict_apache_web_site_visitors_to_specific_ip_addresses.xml' target='_blank'>http://www.anyexample.com/linux_bsd/apache...p_addresses.xml</a>

The mod_mime_magic module is available for Apache 1.3 but needs to be compiled. It comes with a performance penalty because all files need to be inspected. Are you sure this module is required?

The sample config for that PHP package seems to be for Apache 2+ as well. Are you sure this package works also with Apache 1.3? I could not find the requirements.
GreetZ
http://dingetje.homeip.net

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1004
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby Burma » Tue Feb 26, 2008 3:32 am

Hello dingetje and thank's for your answers.

Well I think the package should work with Apchae 1.3 because in the script that launch apache (mediacenter) there is a specific treatment for Apache 1.3.

With some minor change in the script mediacenter and in the httpd/httpd.conf (a comment before the line that loads extra modules), i have succed to launch a new instance of Apache which listen on the port 26180 and it works fine when i try to listen some mp3 file (via the TV decoder). But I have http errors 206 with all video files (avi, mov , vmw). So I thaught it is perhaps because of the extra modules that are not loaded especially mod_mime_magic.
User avatar
Burma
Newbie
 
Posts: 13
Joined: Tue May 04, 2004 12:58 pm
Location: Angers, FRANCE


Return to 3rd Party Package Support for FREESCO v0.3.x

Who is online

Users browsing this forum: No registered users and 2 guests

cron