Setting Up Email Server

Support section for FREESCO v0.3.x 3rd Party Packages

Postby Thasaidon » Sun Aug 26, 2007 2:15 pm

Well, there are a lot of things that don't seem right to me...
but I don't really know how Exim works...

to name a couple...
Code: Select all
bt.getmyip.com in "! +local_domains"? no (matched "! +local_domains")
dnslookup router skipped: domains mismatch
and
Code: Select all
file lookup required for bombtek
in /etc/aliases
lookup failed
expanded:
file is not a filter file

but the one thing that mismatches with my Exim config file is this:
Code: Select all
rda_interpret (string): ${lookup{$local_part}lsearch{/etc/aliases}}

In my config there is a * between lsearch and {/etc

So edit your configure file and look for this part of code
Code: Select all
system_aliases:
  driver = redirect
  allow_fail
  allow_defer
  data = ${lookup{$local_part}lsearch*{/etc/aliases}}
# user = exim
  file_transport = address_file
  pipe_transport = address_pipe
and add the * as seen in the code above.

I'm not sure this is the solution, but it's the one thing that is different.

Also, I would add your domain to the "relay_from_hosts" section in the configure file like this
Code: Select all
hostlist relay_from_hosts = 127.0.0.1 : 192.168.1.0/24 : bt.getmyip.com
Experience shared, is experience gained.

Thasaidon's Freesco Page




Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Postby BomBtek » Sun Aug 26, 2007 4:52 pm

I don't get any msg's when starting exim tried both normal boot and stop/starting from the cmd line.

Zedde, not sure what you mean by using the local IP when conf OL? I am already using Freesco's addy (192.168.1.1) and using bt.getmyip.com would resolve to the same as long as I am internal correct? Using external would resolve my modem's IP?

Thasaidon, what ver of exim are you using? I'm using the latest 4.50 by phbc50.
I did change what you suggested.

Still no change I tried seting up my mail account with Opera and get this msg:

<span style='color:red'><span style='font-size:8pt;line-height:100%'>
Mail and chat
bombtek@bt.getmyip.com
Sending e-mail failed. Maybe the SMTP server is not set up properly? E-mail queued.
Mail and chat
bombtek@bt.getmyip.com
POP3 server unavailable. Network problems? [Server response:-ERR AVG POP3 Proxy Server: Cannot connect to the mail server!]

</span></span>

same as OL

Here's a snip of the exim log:

<span style='font-size:8pt;line-height:100%'>
2007-08-26 16:37:08 1IPPnA-0001Ra-KI H=ws001.inet (ws001) [192.168.1.21] F= temporarily rejected after DATA
Envelope-from:
Envelope-to:
P Received: from ws001.inet ([192.168.1.21] helo=ws001)
by bt.getmyip.com with esmtp (Exim 4.50)
id 1IPPnA-0001Ra-KI
for bombtek@earthlink.net; Sun, 26 Aug 2007 16:37:08 -0500
F From: "bombtek"
T To:
Subject: test2
Date: Sun, 26 Aug 2007 16:37:19 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0028_01C7E7FF.5EF88310"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Thread-Index: AcfoKNNAvT8+Ox74Rji2QOPB57sSeQ==
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
2007-08-26 16:37:35 1IPPnb-0001Rs-9o H=ws001.inet (ws001) [192.168.1.21] F= temporarily rejected after DATA
Envelope-from:
Envelope-to:
P Received: from ws001.inet ([192.168.1.21] helo=ws001)
by bt.getmyip.com with esmtp (Exim 4.50)
id 1IPPnb-0001Rs-9o
for bombtek@earthlink.net; Sun, 26 Aug 2007 16:37:35 -0500
F From: "bombtek"
T To:
Subject: test2
Date: Sun, 26 Aug 2007 16:37:41 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_002C_01C7E7FF.6EDE5610"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Thread-Index: AcfoKNNAvT8+Ox74Rji2QOPB57sSeQ==
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
2007-08-26 16:40:15 1IPPqB-0001S7-Je H=pop-tawny.atl.sa.earthlink.net [207.69.195.67] F= temporarily rejected after DATA
Envelope-from:
Envelope-to:
P Received: from pop-tawny.atl.sa.earthlink.net ([207.69.195.67])
by bt.getmyip.com with esmtp (Exim 4.50)
id 1IPPqB-0001S7-Je
for bombtek@bt.getmyip.com; Sun, 26 Aug 2007 16:40:15 -0500
P Received: from fl-67-77-85-108.dhcp.embarqhsd.net ([67.77.85.108] helo=ws001)
by pop-tawny.atl.sa.earthlink.net with esmtp (Exim 3.36 #1)
id 1IPPqA-0000Hl-00
for bombtek@bt.getmyip.com; Sun, 26 Aug 2007 17:40:14 -0400
F From: "BT"
T To:
Subject: test123
Date: Sun, 26 Aug 2007 16:40:24 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0030_01C7E7FF.CD78EF00"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Thread-Index: AcfoKbXSyupo88CASsCaIQBgbmDkSg==
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
I Message-Id:
2007-08-26 16:40:22 1IPPqI-0001S8-1d H=fall-lakeland.atl.sa.earthlink.net [207.69.195.103] F= temporarily rejected after DATA
Envelope-from:
Envelope-to:
P Received: from fall-lakeland.atl.sa.earthlink.net ([207.69.195.103])
by bt.getmyip.com with esmtp (Exim 4.50)
id 1IPPqI-0001S8-1d
for bombtek@bt.getmyip.com; Sun, 26 Aug 2007 16:40:22 -0500
P Received: from pop-tawny.atl.sa.earthlink.net ([207.69.195.67])
by fall-lakeland.atl.sa.earthlink.net with esmtp (Exim 4.34)
id 1IPPqC-0005HZ-Hy
for bombtek@bt.getmyip.com; Sun, 26 Aug 2007 17:40:16 -0400
P Received: from fl-67-77-85-108.dhcp.embarqhsd.net ([67.77.85.108] helo=ws001)
by pop-tawny.atl.sa.earthlink.net with esmtp (Exim 3.36 #1)
id 1IPPqA-0000Hl-00
for bombtek@bt.getmyip.com; Sun, 26 Aug 2007 17:40:14 -0400
F From: "BT"
T To:
Subject: test123
Date: Sun, 26 Aug 2007 16:40:24 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0030_01C7E7FF.CD78EF00"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Thread-Index: AcfoKbXSyupo88CASsCaIQBgbmDkSg==
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
I Message-Id: </span>

Looks like I am recieving msgs from sent from my earthlink account, but I can't recieve them onto a mail client and from the looks of the log it appears that my earthlink account is rejecting mail sent from exim? That is if I am even reading the logs correctly....

Thanks for the continued help:D

[EDIT]

Attached is a new report.txt looks like in the dmesg section there are some rejects on port 25?

I also checked the exim_paniclog and found this:

<span style='font-size:8pt;line-height:100%'>
2007-08-26 11:23:47 1IPKtv-00022S-Bc malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 11:32:33 1IPL2P-00023J-CH malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:32:41 1IPPir-0001PA-AT malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:32:47 1IPPix-0001PB-MV malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:33:58 1IPPk6-0001PV-40 malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:34:43 1IPPkp-0001PY-HF malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:35:08 1IPPlE-0001Pb-SX malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:36:03 1IPPm7-0001Pe-3h malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:37:08 1IPPnA-0001Ra-Ht malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:37:08 1IPPnA-0001Ra-KI malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:37:35 1IPPnb-0001Rs-9o malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:40:15 1IPPqB-0001S7-Je malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:40:22 1IPPqI-0001S8-1d malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:46:10 1IPPvu-0001Th-3R malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2
2007-08-26 16:49:45 1IPPzM-0001Tq-VQ malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2</span>

Mean anything to anyone?
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby dRB » Sun Aug 26, 2007 10:59 pm

2007-08-26 16:49:45 1IPPzM-0001Tq-VQ malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie). errno=2

Mean anything to anyone?


yes. this is a problem that will cause some side-effects. so my best suggestion is to fix this problem first.

I see in your report that you are not running any antivirus. so make sure that the sections in your exim.conf file (that are av related) are remmed out. and then restart exim. I've found that sometime just restarting exim is not enough. where a system restart was more helpful.

it would be nice to see your exim.conf file, to determine any errors in configuration.

dRB
Please bear with me ... I seemed to have lost my marbles.
User avatar
dRB
Junior Advanced Member
 
Posts: 196
Joined: Tue Apr 30, 2002 2:08 am
Location: Dryden, Ontario. CANADA

Postby Thasaidon » Mon Aug 27, 2007 1:22 am

The denies in your log on port 25 are from an Earthlink IP
Code: Select all
EarthLink, Inc. EARTHLINK2000-D (NET-207-69-0-0-1)
207.69.0.0 - 207.69.255.255
ITC Deltacom MINDSPRING-DEDA-C300 (NET-207-69-195-0-1)
207.69.195.0 - 207.69.195.255

This means that Exim (Freesco) is blocking inbound connections on port 25.
You need to open this port if you want to recieve mail in Exim from the outside world.

Also...
I'm using an older version of Exim and Teapop:
exim_4.20_phbc50* teapop3x*

Also...
Zedde, not sure what you mean by using the local IP when conf OL?
What Zedde probably meant was what you already did... replacing your domain with Freesco's IP in your Outlook settings... but as you said yourself, that does not make any difference.

I would suggest the same as dRB and comment out (using the # ) any AV or FILTER related options in your Exim config.
(my older version of Exim does not have all those options so I can't tell you what to comment out)
Experience shared, is experience gained.

Thasaidon's Freesco Page




Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Postby BomBtek » Mon Aug 27, 2007 4:16 pm

I have port 25 opened up on my DSL modem, should I open it as well on freesco? I always thought freesco's PF was for inside the LAN.

Attached is my exim.conf



Thanks again for the continued help.
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby BomBtek » Mon Aug 27, 2007 4:16 pm

Here's my rc_exim from /pkg/rc
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby Thasaidon » Tue Aug 28, 2007 1:05 am

I have port 25 opened up on my DSL modem
To receive e-mail from the outside world, you need to forward port 25 from your DSL router/modem to your Freesco and make sure it's firewall also accepts incoming connections.
Then on Freesco you need to open port 25 in your firewall.
Note!
Opening a port in your firewall is not the same as forwarding a port.

When opening a port, Freesco will accept connections on that port.
Meaning, any service running on Freesco (like your Exim) is able to accept connections on that port.

When forwarding a port, Freesco will "pick up" the incoming traffic and forward those to the specified IP on your LAN. So the traffic goes through Freesco.

It looks like Exim is already configured to allow incoming traffic at port 25
Code: Select all
      firewall) # If you want to make exim accessible from the internet comment
    IIPd=${Pd:-reject};[ "i$LOG" = iNo ] && LOG= || LOG=-o
               # ipfwadm -I -a $Pd -P tcp -W $INET -D 0/0 25 $LOG
               # ipfwadm -I -a $Pd -P udp -W $INET -D 0/0 25 $LOG

But when I telnet to your domain on port 25, I get no response at all.

So have you just allowed port 25 on your dsl router or have you also forwarded it?

Also, when looking at your configure file, I see this
Code: Select all
domainlist relay_to_domains = bt.getmyip.com : router.inet
maybe you need to add localhost to that line
Code: Select all
domainlist relay_to_domains = bt.getmyip.com : router.inet : localhost
Experience shared, is experience gained.

Thasaidon's Freesco Page




Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Postby BomBtek » Tue Aug 28, 2007 4:37 pm

Ok,

I changed the exim.conf and added the localhost as you suggested.

I also confirmed my DSL router settings as shown below:

Image

I hate this stupid DSL modem. If I turn off the NAT features I can't get on the net. Nor can I if I put it in bride mode. So I had it set to fwd all ports, but that apparently wasn't working. I added a specific line for port 25.

Not sure if it accessable from outside my LAN yet.

Still no worky..
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby BomBtek » Tue Aug 28, 2007 4:52 pm

Woohoo I got it figured out!!!

I was looking at the Exim_paniclog and noticed it said "malware" I am not running any malware or AV addons so I did a search and found the answer in this <a href='http://www.freesco.org/support-forum/index.php?showtopic=16093' target='_blank'>post</a>

Now I can recive emails with outlook, but not send any b/c everyone seems to block them as spam.. Just have to figure out the smtp relay thing.

I also am getting new errors in the panic log too:

<span style='font-size:8pt;line-height:100%'>
2007-08-28 16:34:14 1IQ8hS-0001lm-EI spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed: Connection refused
2007-08-28 16:34:14 1IQ8hS-0001lm-EI spam acl condition: all spamd servers failed
2007-08-28 16:34:14 1IQ8hS-0001lm-EI spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed: Connection refused
2007-08-28 16:34:14 1IQ8hS-0001lm-EI spam acl condition: all spamd servers failed
</span>

Gonna try reming the spam lines out now.. Seems the exim conf file was defaulted to using all that stuff..

When I get that figured out I will post the new exim.conf as I have changed much trying to fix this stupid thing I want it to be correct..

Thanks for all the help, couldn't have done it otherwise!!! ^_^
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby dingetje » Tue Aug 28, 2007 5:00 pm

Relaying your outgoing mail messages via your ISP's mail server is not too hard (this usually gets you removed from spam lists unless your ISP's mail server is on the black list too...), just follow the steps <a href='http://dingetje.homeip.net/dokuwiki/freesco/howtos/how-to_setup_a_mail_server#adding_a_default_route' target='_blank'>here</a>

BTW: your port 25 is now open to the world AND exim is responding, congrats!

You may also want to configure your exim to handle multiple virtual domains. There's a good article about that too in the wiki.
GreetZ
http://dingetje.homeip.net

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO Crazed !!
 
Posts: 1001
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby BomBtek » Tue Aug 28, 2007 8:17 pm

Sweet thanks for the help! I can recieve email from outside the LAN, but.....
Looks like earthlink won't let me relay... :( Log below...

<span style='font-size:8pt;line-height:100%'>
Aug 28 20:08:19 - dnsmasq[1941]: reply mail.earthlink.net is 209.86.93.204
Aug 28 20:08:19 - exim[8739]: 2007-08-28 20:08:19 1IQBsI-00027y-In == bombtek@earthlink.net R=smart_route T=remote_smtp defer (-54): remote deliveries suppressed
Aug 28 20:08:19 - exim[8740]: 2007-08-28 20:08:19 1IQBu4-00028d-Ho == the_original_bomtek@earthlink.net R=smart_route T=remote_smtp defer (-54): remote deliveries suppressed
Aug 28 20:08:40 - exim[8954]: 2007-08-28 20:08:40 exim 4.50 daemon started: pid=8954, -q5m, listening for SMTP on port 25 (IPv4)
Aug 28 20:08:40 - exim[8956]: 2007-08-28 20:08:40 exim 4.50 daemon started: pid=8956, -q30m, not listening for SMTP
Aug 28 20:08:40 - exim[8959]: 2007-08-28 20:08:40 1IQBu4-00028d-Ho == the_original_bomtek@earthlink.net R=smart_route T=remote_smtp defer (-54): remote deliveries suppressed
Aug 28 20:08:40 - exim[8966]: 2007-08-28 20:08:40 1IQBsI-00027y-In == bombtek@earthlink.net R=smart_route T=remote_smtp defer (-54): remote deliveries suppressed
Aug 28 20:08:40 - exim[8975]: 2007-08-28 20:08:40 1IQBu4-00028d-Ho == the_original_bomtek@earthlink.net R=smart_route T=remote_smtp defer (-53): retry time not reached for any host
Aug 28 20:08:40 - exim[8977]: 2007-08-28 20:08:40 1IQBsI-00027y-In == bombtek@earthlink.net R=smart_route T=remote_smtp defer (-53): retry time not reached for any host
Aug 28 20:08:47 - popa3d[8993]: Session from 192.168.1.21
</span>

At least that's what it looks like to me...
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby Thasaidon » Wed Aug 29, 2007 4:11 am

Did you also configure the authentication to your ISP (if needed that is)?
Experience shared, is experience gained.

Thasaidon's Freesco Page




Image
User avatar
Thasaidon
Advanced Member
 
Posts: 411
Joined: Tue Feb 05, 2002 9:38 am
Location: The Netherlands

Postby dingetje » Wed Aug 29, 2007 8:05 am

According to <a href='http://kb.earthlink.net/case.asp?s=st%3D518%2Ce%3D0000000001638235660%2Ck%3D1215%2Csxi%3D9&article=23490' target='_blank'>this</a> (from the earthlink support knowledge base) you need SMTP authentication enabled to use earthlink's outgoing mail server.

Why you should use secure SMTP to send email

EarthLink's outgoing mail servers are now using authenticated SMTP (ASMTP) to help fight spam. As a result, you must update your email settings to continue sending mail from our servers. ASMTP requires you to enter your email password before sending email. This simple step blocks unauthorized outgoing messages and helps reduce the distribution of spam.


SMTP AUTH can be configured in exim's config and is described in the wiki document <a href='http://dingetje.homeip.net/dokuwiki/freesco/howtos/how-to_setup_a_mail_server#smtp_auth' target='_blank'>here</a>.

P.S. I just realized this thread was in FREESCO 03x support so I've moved it to where it belongs namely 3rd party packages support for FREESCO 03x.
GreetZ
http://dingetje.homeip.net

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO Crazed !!
 
Posts: 1001
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby BomBtek » Wed Aug 29, 2007 8:17 pm

I added the lines in the exim.conf for SMTP auth when I set up the relay yesterday, that's when I posted the errors..

Here's my exim.conf snip:

<span style='font-size:8pt;line-height:100%'>
### listed in the relay_from_host setting near the start of this file.

begin authenticators

login:
driver = plaintext
public_name = LOGIN
server_prompts = "Username:: : Password::"
server_condition = "${if and {{!eq{${lc:$1}}{ppp}}{!eq{$1}{}}{!eq{$2}{}} \
{crypteq{$2}{${extract{1}{:} \
{${lookup{$1}lsearch{/etc/passwd}{$value}{*:*}}}}}}}{1}{0}}"
server_set_id = $1
client_send = ": bxmbtxk@earthlink.nxt : xxxxxxxx"
I
plain:
driver = plaintext
public_name = PLAIN
server_condition = "${if and {{!eq{${lc:$2}}{ppp}}{!eq{$2}{}}{!eq{$3}{}} \
{crypteq{$3}{${extract{1}{:} \
{${lookup{$2}lsearch{/etc/passwd}{$value}{*:*}}}}}}}{1}{0}}"
server_set_id = $2

######################################################################
</span>

Added x's in the config for privacy reasons, but I believe the syntax to be correct.
"Initial Success Or Total Failure"
User avatar
BomBtek
Junior Member
 
Posts: 44
Joined: Thu Jun 20, 2002 10:39 am

Postby dingetje » Thu Aug 30, 2007 5:49 am

You may have to add/change:

Code: Select all

smart_route:
  driver = manualroute
  domains = !+local_domains
  transport = remote_smtp
  route_list = * smtpauth.eartlink.net

remote_smtp:
 driver = smtp
 hosts_require_auth = smtpauth.eartlink.net


where smtpauth.earthlink.net is the name of your ISP's mail server. They mention something about port 587 but when you connect via the earthlink network (as in your case) port 25 should work too.

<a href='http://wiki.exim.org/' target='_blank'>http://wiki.exim.org/</a> may be of help
GreetZ
http://dingetje.homeip.net

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO Crazed !!
 
Posts: 1001
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

PreviousNext

Return to 3rd Party Package Support for FREESCO v0.3.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron