Pl Script Error With Gd Modul Use

Support section for FREESCO v0.3.x 3rd Party Packages

Postby lgrfbs » Thu Mar 29, 2007 3:40 pm

I gets this errors:
Can't load '/usr/local/lib/perl5/site_perl/5.6.1/i386-linux/auto/GD/GD.so' for module GD: File not found at /usr/local/lib/perl5/5.6.1/i386-linux/DynaLoader.pm line 206.
at ./z.cgi line 3
Compilation failed in require at ./z.cgi line 3.
BEGIN failed--compilation aborted at ./z.cgi line 3.
Press any key to continue...


pl-file:
use GD;
print $GD::VERSION, "\n";


I have try this:
Reinstalled: perl_5.6.1_dingetje
Tryed to install install GD from CPAN (perl -MCPAN -e "install GD")
Checked if DynaLoader.pm & GD.so are in the path.

The system is:
Freesco 0.3.5 whit this package is installed:
edrive_1.02_gnork e2fs_1.01_gnork
mc-4.6.0-lightning usergui_1b_tiger
perl_5.6.1_dingetje openssl-0.9.6g_user_nadegda
apache_1.3.27_dingetje antivir_2.1.2_phbc50

So how do I fix this?
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby dingetje » Fri Mar 30, 2007 4:24 am

Look carefully when you reinstall the perl_5.6.1_package. During post install a tarball 'i386-linux.tgz' is supposed to be extracted. Sometimes this step fails!
(You probably have to scroll back to see this error)

The reason for this 2-step approach is because the path names in p.e.r.l are getting too long for the standard available star (serial tar) command on a bare-bone FREESCO.

If reinstall keeps failing, try this:

Code: Select all
cd /usr/local/lib/perl5/site_perl/5.6.1
snarf -n http://dingetje.homeip.net/downloads/perl5/i386-linux.tgz
tar -zxvf i386-linux.tgz


if the last step fails with 'tar: No such file or directory' you need to install my utils_1.1_dingetje package first.
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby lgrfbs » Fri Mar 30, 2007 8:55 am

I tryed you "code" step by step but get this:
Code: Select all
Can't load '/usr/local/lib/p[I]erl5/site_p[/I]erl/5.6.1/i386-linux/auto/GD/GD.so' for module GD: File not found at /usr/local/lib/p[I]erl5/5.6.[/I]1/i386-linux/DynaLoader.pm line 206.
 at ./z.cgi line 3
Compilation failed in require at ./z.cgi line 3.
BEGIN failed--compilation aborted at ./z.cgi line 3.
Press any key to continue...


I added the log file of the reinstall & if you want so I have a AVI of the test whit yous step by step.
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby lgrfbs » Fri Mar 30, 2007 9:35 am

In my old Freesco 0.3.4 all works fine and have package name
Old freesco 0.3.4
-------------------------------------------------------------------------------
banip_0.13_ysby-03x          antivir_2.1.2_phbc50
perl_5.6.1_dingetje          seti_3.0.3_dingetje
mc-4.6.0-lightning           mysql-4.1.7a-lightning
usergui_1b_tiger             lcdproc_0.4.5_dingetje
netwatch_1.0b_dingetje       thttpd+_php-4.2.3_the.icy.k
e2fs_1.01_gnork              edrive_1.02_gnork
utils_1.1_dingetje           UpLA_1.3_the-icy-k
shaper-2.2.12-lightning      mrtg_2.9.12a_ionelmi
banip_0.15_ysby-03x          banip_0.17_ysby-03x
hosts-1.1-lightning          rrdtool_1.0.40_dingetje
-------------------------------------------------------------------------------


I installed the utils_1.1_dingetje inne my freesco 0.3.5 now and reinstall
perl new loggfile, still same error for the pl-file.
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby dingetje » Fri Mar 30, 2007 2:47 pm

:huh: :huh: :huh: :huh:

both installs look good, the site_p.e.r.l stuff is unpacked here:

Unpacking i386-linux stuff for site_p.e.r.l...

and when an error occurs, that is where it goes wrong.

However, I don't understand the italic bbcodes in your previous post, unless you made a mistake posting your code?
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby dingetje » Fri Mar 30, 2007 2:54 pm

What do you get when you execute this command?

Code: Select all
ls -la /usr/local/lib/perl5/site_perl/5.6.1/i386-linux


and this?
Code: Select all
[root@Freesco] ls -la /usr/local/lib/perl5/site_perl/5.6.1/i386-linux/auto/GD
drwxr-xr-x   2 root          root             8192 Nov 23 22:42 .
drwxr-xr-x  16 root          root             8192 Nov 23 22:42 ..
-r-xr-xr-x   1 root          root            70495 Dec 29  2002 GD.so
-r--r--r--   1 root          root                0 Dec 29  2002 GD.bs
-r--r--r--   1 root          root               81 Dec 29  2002 autosplit.ix
-rw-r--r--   1 root          root               69 Dec 29  2002 .packlist


FYI: when I run your little script, it outputs this:
[root@Freesco] p.e.r.l gd.pl
2.041


Don't mind the dots in p.e.r.l the security on this server is starting to piss me off... :angry:
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby lgrfbs » Fri Mar 30, 2007 4:05 pm

My site_perl is same as you write like: site_p.e.r.l
the BBcode stop the forum from go bad on me.

I will return whit a edit in this post then i tested all you write.
----------------------------------------------------------------------------
look in the file: Answer_logg.txt
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby lgrfbs » Fri Mar 30, 2007 5:49 pm

Can it be that I installed apache_1.3.27_dingetje before perl_5.6.1_dingetje so
somthig is wrong at the begining of all?

Can it be a ideé to remov apache_1.3.27_dingetje and perl_5.6.1_dingetje
then is done instal them in corredt order?
like perl_5.6.1_dingetje and after that apache_1.3.27_dingetje
can this do the trick?
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby dingetje » Mon Apr 02, 2007 1:11 am

Your site_p.e.r.l directory looks OK to me.

I doubt if re-installing p.e.r.l and apache will fix this, the correct order is indeed to install p.e.r.l first and then apache.
Maybe a library is missing or is missing the execute bit?

try this:
Code: Select all
chmod +x /pkg/lib/*
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby lgrfbs » Mon Apr 02, 2007 10:47 am

The
Code: Select all
chmod +x /pkg/lib/*
give me a new promt only but the problem
with the pl file is still the same ,Sorry.

"the correct order is indeed to install p.e.r.l first and then apache." and I started
with apache and installed p.e.r.l then the apache installer asked of it.
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby dingetje » Tue Apr 03, 2007 5:57 pm

I'm sorry, but I've ran out of ideas. I don't know whats wrong on your system.
:(
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Postby Lightning » Tue Apr 03, 2007 8:07 pm

Try disabling the perl_module in the Apache configuration and restart the web server and see what happens.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Postby lgrfbs » Wed Apr 04, 2007 1:03 pm

Like so: <a href='http://lgrfbs.dyndns.org/1c/Freesco_Deaktive_perl.avi' target='_blank'>Freesco_Deaktive_perl.avi</a> (13.5Mb)?

Can the kernel have somethig too do with the problem?
Freesco - PicoPhone & NetMeeting: robb-h.mine.nu
Intressanta hemsidor: JemtRallarna LGR FBS Min Labbsida
Fel 404 = Felet är 404mm från skärmen.
User avatar
lgrfbs
Junior Advanced Member
 
Posts: 100
Joined: Mon Mar 01, 2004 5:37 pm
Location: Jamtland

Postby Lightning » Wed Apr 04, 2007 9:24 pm

yes, that was what I stated to do and I am sorry I mis understood the aplication you are using.
However watching the error and carefiully looking at the code it actually say's that is a common place for errors to occure and it is not usually because of perl. But rather the initial code that is calling perl. So in your script what is it trying to do on line 3 and when you answer that question you can figure out how to solve the problem.
If you are afraid that you might make a mistake. The chances are high that you will never learn anything.
User avatar
Lightning
FREESCO GOD !!
 
Posts: 12080
Joined: Wed Nov 14, 2001 6:50 am
Location: Oregon, USA

Postby dingetje » Thu Apr 05, 2007 3:02 am

On my box:

[root@Freesco] cat gd.pl
use GD;
print $GD::VERSION, "\n";

[root@Freesco] perl gd.pl
2.041
GreetZ
http://dingetje.hopto.org

"Software is like sex: it's better when it's free." - LINUS TORVALDS
User avatar
dingetje
FREESCO GURU !!
 
Posts: 1010
Joined: Wed Nov 14, 2001 12:13 pm
Location: The Netherlands

Next

Return to 3rd Party Package Support for FREESCO v0.3.x

Who is online

Users browsing this forum: No registered users and 2 guests

cron