Page 1 of 1

Tried 0.4.2; didn't like it.

PostPosted: Sat Jul 18, 2009 3:49 pm
by phillipsjk256
This is the first time I tried upgrading to a new major revision of Freesco. I may have border-line asperger's (syptoms: bright, anti-social, resistant to change (overdiagnosed IMO)), but I think I have some legitimate complaints. I think I now understand why some people are sticking with the 0.2.7 revision (that I have never used). I have enjoyed your minor revisions of the 0.3.x series, even though some of the experiments (like bandwidth control) didn't always work out.

Initial Boot Screen
White on Dark blue shows up as normal intensity amber on normal intensity amber on my mono screen. I edited /syslinux.cfg on my copy to use a black background. I Lol'ed when I saw why every line ended with blue on blue ;)

Greeting screen
After Freesco boots, user is greeted with this message:
The GNU GPL license is located in the file. By using this product you are agreeing to the terms listed in that license and all other specific licenses for applications used in freesco v0.4.2

That message is contradicted by section 5 of the GPL version 2:
You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

One of the reasons I use Linux is that I hate click-wrap licenses with a passion. You are diminishing one of the major benefits of free software by suggesting that the end-user must agree to a license to use the software. Debian just uses a boiler-plate disclaiming warranties and reminding the user that the software is subject to copyright:
The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Configuration script
Before configuring the router, I was a little annoyed by the short screen-saver delay. As it is covered by the configuration script, I assume that is so the user has a chance to see what it looks like :)

The new configuration script seems to do a lot of hand-holding: too much hand-holding. I like to jump around a bit in the advanced configuration screen. After configuring the (ISA) network cards I was prompted to set up the networks. I was really expecting to edit isapnp.conf. Configuring the networks is still trial and error because the MAC addresses are still not listed. The hand-holding gets in the way at that point; but, in truth, I did not get that far.

The script stopped responding when I was trying to configure the null modem cable. I tried to change the settings in order: attempting to clear the initialization string before telling Freesco that it is not really a modem. If the string is left blank, the default ATZ is used. I tried "", '', and - , one of which may have broken the script. The other possibility is that changing some settings have immediate side-effects (like trying to intialize the (non-existant) modem), which would be a BAD thing.

I see where your are trying to go with this, and respectfully disagree. Having things happen automatically can be confusing, not "easy to use." Over the years, I have come to accept the automatic configuration of harddrives, monitors, mice, etc. One thing you should be mindful of is that there is not always a sensible default. Sometimes editing text files is just easier than using a menu.

Re: Tried 0.4.2; didn't like it.

PostPosted: Sun Jul 19, 2009 12:08 pm
by Lightning
You definitely have some valid points and I may look into some of them for possible changes. However I suspect the biggest issue here is the major format change if you are accustomed to 03x along with the system requirements which have increased in the 04x series. As with all changes sometimes there are some that people like and some that people don't like. The best parts of the new system in my opinion you never even got to, which is the new ext2 and package system. The setup it's self is definitely a LOT different, but again it now has the capability to support other languages as does the rest of the system. So there are always trade offs and when installed on a Pentium class machine it runs quite well.
But again there was nothing wrong with the 03x series and if you are happy with it then by all means continue using it as I will continue to support it.

Thanks for your input and I am at least still hoping that your dislike of the 04x series is in a minority.

Re: Tried 0.4.2; didn't like it.

PostPosted: Mon Jul 20, 2009 5:09 pm
by phillipsjk256
Ok, I forgot the disk in my Debian machine; so tried going through the configuration script with 96MB or RAM (instead of 24).

The setup program did not get stuck on configuring the modem. I was still unable to use an empty "init" string. I noted that trying to use the arrow keys to use the pointer is very slow. So slow that the keyboard buffer is quickly exhausted resulting in beeping. This may be what I interpreted as the "script not working". I don't think lack of memory was a problem, because I was able to switch virtual consoles. I was not able to set the init string to '' or - (so think they may have special meaning).

The Plug&Play ISA NIC was configured upon restart. Don't know how the NIC configuration screen affects the settings. I'm temped to see what happen with more than one card/ mix of Pnp/non PnP cards.

After going though the config script with a color monitor, I noted that you use a lot more color-coding. (more dangerous settings being red) Obviously, keeping the text-based warnings is a good idea as well, in case of color-blindness. In my case, I am only color-blind using a mono monitor.

I left the "admin" password unset and got a nice big warning on boot :)

It did not complain when I set the root password to "root" (but avoiding guessable passwords would probably require a dictionary of some kind).

Re: Tried 0.4.2; didn't like it.

PostPosted: Mon Jul 20, 2009 8:17 pm
by Lightning
You have definitely found a glitch in the INIT sting setup caused by some coding that automatically adds ATZ into the system if it is left blank. Which from a support point of view I have had to point out an empty INIT string way to many times and thought it was a good idea to remove making that as a mistake. But in hind sight I can see now where it needs to be made as a possible mistake. Which it could still be done manually in the 04x series by editing the /etc/system.cfg file and the same file in /boot/etc/
So this will be something repaired in 0.4.3

Also with regards to the main system requirements, I used to test every single version on a 386 sx 16 with 8Mb of ram up until 0.3.7 to prove the system could run on it and made many changes to coding to improve minimum performance. However at 0.3.7 the memory requirements had to be increased due to the new ramdisk. I also finally recycled that old 386 and now a Pentium 90 is my minimum test machine and my minimum recommended hardware. This was due to so many high speed connections that require that much CPU to process the data and standard modem support is much less in demand. I also was getting some negative input maintaining the OS to support such hardware. As for cursor control I have seen where there are issues on slower systems and left the direct character input in place specifically for those cases, but left the cursor control in place because..... 'well I liked it' :roll:

Thanks for the additional input.

Re: Tried 0.4.2; didn't like it.

PostPosted: Tue Jul 21, 2009 12:42 am
by phillipsjk256
I understand wanting to move away form old hardware. Even though I am using ISA NICs exclusively, I think Freesco could be made so much easier to configure if you dropped ISA support altogether. Of course, floppy disks are "legacy" as well.

For my router, I monitor the memory usage with free if I suspect a memory problem. When you added the extra ram disk I bumped the RAM from 16 to 24MB. After my router overheated (due to dust), I under-clocked it. :arrow: For something with a load average of 0.00 0.00 0.00, it sure takes noticeably longer to do some things. :roll: